docker是最近火热的linux容器,需要3.8以上内核,官方推荐Ubuntu linux,近期试用,总结如下:

1. 首先更新系统

sudo apt-get update
sudo apt-get upgrade

2. 修改源

sudo vim /etc/apt/sources.list.d/docker.list

输入

deb https://get.docker.io/ubuntu docker main
:wq

保存

3. 更新并安装lxc-docker

sudo apt-get update
sudo apt-get install lxc-docker

4. 检查是否安装成功,输入

sudo docker version

输出

[sudo] password for duyaofei:
Client version: 1.4.1
Client ...... 

查看完整文章